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CHAPTER

ONE

BIOMOVIES

1.1 Brief description

Documentation for Biomovies, the cross-platform 3D biological structure video editor. This cross-platform, open-
source software allows the creation of movies starting from a 3D biological structure file such as a PDB or aMMCIF
file. Additionally, the application accepts trajectories coupled with its corresponding topology. The accepted trajectory
formats are NETCDF, XTC and DCD.
Thanks to its simplicity and the intuitive interface, users can build videos easily and quickly. The application allows the
creation of low resolution and HD videos as well as animated GIF images.
The projects can be saved into .biomovies files for the sake of sharing or editing them later. Templates can be exported
too, allowing to apply the same edition to different biological structures.
This is a non-profit experimental software in its Beta version, so be aware that some bugs can happen during the
execution. Please save your projects as often as you can and let us know if some bug is found.
Visit the official website for watching demonstration videos and tutorials.
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1.2 Demo

Visit the website gallery for seeing demos.

1.3 Documentation & help

All the documentation is accessible through Read the Docs.

1.4 Software / Hardware requirements

• macOS:Mac OSX 10.12+ supported, 16GB of RAM recommended
• Linux: Ubuntu 18.04 or greater, 16GB of RAM recommended
• Windows: Windows 10, 16GB of RAM recommended

1.5 Installation

Please take a look at the installation section in this same documentation.

1.6 Features

Though we have put all our effort in making Biomovies a fully cross-platform software, there are a fewminor features
not available in some of the operating systems:
Feature | macOS | Ubuntu |Windows
Create projects | ✓ | ✓ | ✓
Run trajectories | ✓ | ✓ | ✓
Export templates | ✓ | ✓ | ✓
Create preview videos | ✓ | ✓ | ✓
Create HD videos | ✓ | ✓ | ✓
Create animated GIFs | ✓ | ✓ | ✓
Dock menu / JumpList | ✓ | × | ✓
Open recent projects | ✓ | × | ×

2 Chapter 1. Biomovies
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1.7 Technology

This project has been built using Vue JS on top of Electron JS , using the PrimeVue components library to enhance
the user experience.

1.8 Acknowledgements

This project has been developed on top of different JavaScript libraries:
• NGL viewer: web-based molecular graphics for large complexes
• NGL Viewer: a web application for molecular visualization
• FFMPEGWASM
• Animation Timeline Control

1.9 Copyright & licensing

This software has been developed by theMMB group at the IRB Barcelona .
© 2023 Institute for Research in Biomedicine
Licensed under the GPL-3.0 license
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CHAPTER

TWO

INSTALLATION

2.1 macOS

At the moment of launching the current release, the Biomovies macOS binaries are unsigned. That means that macOS
treats them as untrusted software. So, for executing it, please follow the next steps:

• Open the Finder.
• Locate the app (it might be in the Applications folder, or it might still be in your Downloads folder).
• Ctrl-Click or right-click on the app.
• Select Open from the resultant menu and the app will be opened anyway, and an exception will be created for
opening it normally (i.e. by double-clicking) in future.

If the above steps don’t work, here they are the workarounds for make working both the universal (Intel) and Apple
silicon (arm64) version of Biomovies:

2.1.1 Universal / Intel

A universal binary runs natively on both Apple silicon and Intel-based Mac computers, because it contains executable
code for both architectures. For downloading the Universal version of Biomovies, go to the website download section
and click the macOS Universal button. Note that, though this version works as well with an Apple silicon computer, the
ARM64 version is recommended for being more optimized for this kind of architecture.
Download the dmg file, install the application dragging the icon to the Applications folder, and, before opening the
application, open Settings > Security and Privacy and click Anywhere under the Allow apps downloaded from section:

Note that this option has disappeared fromMac OS High Sierra onwards, so in this case, select App Store and identified
developers. After that, try to open the application and this message will be shown:

4
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Go back to Settings > Security and Privacy and, belowApp Store and identified developers a newmessage will be shown:
“Biomovies” was blocked from opening because it is not from an identified developer
Click the Open Anyway button at right and now the application should work.

2.1.2 Apple silicon / ARM64

AnApple silicon binary runs only in Apple silicon computers. For downloading theApple silicon version of Biomovies,
go to the website download section and click the macOS Apple Silicon button.
Download the dmg file, install the application dragging the icon to the Applications folder, and, before opening the
application, open the Terminal, type the following code and press Enter:

xattr -r -d com.apple.quarantine /Applications/biomovies.app

Now the application should work properly.

2.2 Ubuntu

For downloading the Ubuntu version of Biomovies, go to the website download section and click the Ubuntu button
(.deb and .AppImage binaries available). At themoment of launching the current release, there is only a x64 architecture
binary for Ubuntu.

2.2. Ubuntu 5
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2.2.1 deb

Command line

Open the Terminal and type the following code:

sudo apt install path_to_deb_file

Be sure to put the absolute / relative path, not just the file name.

Graphical User Interface

Right click on .deb file, selectOpenWithOtherApplication and selectSoftware Install. This opensUbuntu Software.
Click Install button:

Now the application is installed in your computer.

2.2.2 AppImage

First off, be sure to have FUSE installed in your coumputer. If not, please, type on terminal:

sudo apt-get install fuse libfuse2 # Ubuntu < 22.04
sudo apt install libfuse2 # Ubuntu >= 22.04

6 Chapter 2. Installation
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Command line

Open the Terminal and type the following code:

chmod +x path_to_AppImage_file
./path_to_AppImage_file

Be sure to put the absolute / relative path, not just the file name.

Graphical User Interface

Double click .AppImage file.

2.3 Windows

For downloading theWindows version ofBiomovies, go to thewebsite download section and click theWindows button.
At the moment of launching the current release, there is only a x64 architecture binary forWindows.
Windows treats the Biomovies executable file as an unrecognized app. So, after double clicking the .exe file, Windows
will open the following window:

Click on More info and then, on Run anyway button for starting the installation.

2.3. Windows 7

https://gbayarri.github.io/biomovies/#download


CHAPTER

THREE

GETTING STARTED

Application home screen
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3.1 New Project

Creating a new project with Biomovies is as easy as clicking the Create new project button (or via menu: Project > New
Project) and selecting a 3D biological structure file (in PDB orMMCIF format) from the user’s computer.
Shortcut: ⌘/Ctrl + ⇧ + N

3.2 New Project with Trajectory

The process of creating a new project with a trajectory starts by clicking the Create new project with trajectory button (or
via menu: Project > New Project with Trajectory) and selecting a 3D biological structure file (in PDB orMMCIF format)
as a topology and its corresponding trajectory (in NETCDF, XTC or DCD format) from the user’s computer. Note that
both files must be selected at the same time, so it’s recommended to have them in the same folder at the time of creating
the new project.
Be aware that, if the trajectory doesn’t fit the topology, errorswill happen in the representation of the structure. It is very
important too that the trajectory is well created and tested with its corresponding topology in a visualization program
such as VMD .
Take into account that, depending on the trajectory size and thememory of the computer, the loading process can take
a while. Consider as well that, if the trajectory is big and the project is saved in a .biomovies file, this file will contain the
trajectory along with the topology. So, consequently, the final size of the project file will be big as well.
In those cases it can be worth considering exporting the project as a template instead of saving it as a project. A template
only saves the project information (but not the structure and the trajectory) and, therefore, the file size is really small.
Shortcut: ⌘/Ctrl + ⇧ + T

3.1. New Project 9
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3.3 Open Project

Just click the Open project button (or via menu: Project > Open Project or Project > Open Recent) and select a .biomovies
file from the user’s computer. A .biomovies file contains all the necessary information of the project, including the 3D
structure file and the trajectory file (if necessary).
Recent projects can be opened as well from the JumpList inWindows and from theApplication dockmenu inmacOS.
Shortcut: ⌘/Ctrl + ⇧ + O

3.4 Import Template

Templates are a very interesting option for applying the same video edition to different structures. They are worth
considering too for sharing a project, since a template only saves the project information (but not the structure and the
trajectory) and, therefore, the file size is really small.
Clicking the Import template button (or via menu: Project > Import Template) will ask to select a .tbiomovies file from the
user’s computer. As the .tbiomovies file only contains the necessary information to create a new project but not the 3D
structure file and the trajectory file (if necessary), after loading it, a new dialog window will ask for this 3D structure
file and the trajectory file (if it is a trajectory template). After these two steps, a new project is created applying the
actions of the template on the new 3D structure (and the trajectory if provided).
Shortcut: ⌘ + ⇧ + I formacOS, Ctrl + Alt + I forWindows / Ubuntu

10 Chapter 3. Getting started
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3.5 Help

A broad documentation has been written and is available in this same Read the Docs. Besides, there are several video
examples available in the Gallery as well as some Tutorials in the official website .

3.6 Common shortcuts

When launching the application, a list of common shortcuts is shown (see figure Application home screen in this same
section). However, a list with all the shortcuts available can be found in the Utilities section.

3.5. Help 11
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VIDEO EDITOR

Video Editor
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4.1 Stage

The stage is the area where the 3D biological structure is represented, the tools bar allows to apply actions to the stage.

4.1.1 Tools

The tools menu is at the top left of the stage and allows users to make some actions over it.

This menu is draggable around all the stage and can be collapsed / expanded by clicking twice on the handler. For
hiding it completely, go to View > Tools in the menu. Click in the same menu for showing it again.

4.1. Stage 13
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Center

Clicking this button centers the structure(s) position on the stage. This button is active only if one single keyframe of
the timeline has been selected.

Background

Clicking this button opens a color picker that allows users to change the background color of the stage.

Click again on the button for hiding the color picker.

Measurements

Clicking this button opens a modal dialog to edit the distances and angles created by users in the stage. For remem-
bering how to draw them, please go to theMouse click actions section.
Measurements with size and color by default:
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Distances

Distances editor before editing size and color:

4.1. Stage 15



Biomovies Documentation, Release 0.5.1

Distances editor after editing size and color:

If only a distance is needed (without label), please set 0 as Label size.

16 Chapter 4. Video Editor
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Angles

Angles editor before editing size and color:

Angles editor after editing size and color:

If only the lines are needed (without label), please set 0 as Label size.
Measurements after size and color edition:

4.1. Stage 17
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Labels

Clicking this button opens a modal dialog to edit the labels created by users in the stage. For remembering how to draw
them, please go to theMouse click actions section.
Labels with size, text and color by default:
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Labels editor before editing text, size color and background:

Labels editor after editing text, size color and background:

4.1. Stage 19
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Label background can be modified. Moreover, it can be disabled as well with the switch beside the background color
selector.
Labels after size, text and color edition:
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Camera type

Switches camera type between orthographic and perspective.

Center view in atom

Click this button and then, select an atom of the structure, the view will be focused into this atom position. This button
is active only if one single keyframe of the timeline has been selected.

Enable / Disable legend

Enables / disables a legend on the bottom right of the stage. This legend shows information for the molecule the mouse
has hovered over in the next format:

Model number | Chain ID | Residue name (Residue long name) Residue number Atom name (or Bond)

Open keyframe editor

Clicking this button opens a keyframe editor.
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In this editor, users can change the rotation and translation of the biological structure.
This button is active only if one single keyframe of the timeline has been selected.

Enable / Disable letterboxing

Enables / disables letterboxing on the stage. Two stripes will appear showing to the user which parts of the stage will be
rendered and which not in case of Creating a New Movie. In some cases (when the screen aspect ratio is 16:9) these
stripes won’t appear.

Click again on the button for removing the stripes from the stage.
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4.1.2 Structure Stage

The stage covers the main part of the screen. In the stage the structure is loaded and represented, and users can interact
with it in several ways.

Zoom / Drag

Before applying rotation, translation or zoom to the stage, a keyframe must be selected in the timeline.
Actions of zoom in and zoom out can be done with the scroll mouse or the trackpad of a laptop, besides, rotation and
translation can be applied as well:

• Clicking on the stage with the left button and dragging will rotate the view.
• Clicking on the stage with the right button and dragging will translate the view.
• Mouse wheel (or using the trackpad with two fingers) on the stage will zoom in or zoom out.

All these modifications in the general orientation of the structure will be applied to the selected keyframe. That means
that, in a clip, the first and the last frame can have different rotation, translation or zoom. Biomovies will take care
of the interpolation between frames.

4.1. Stage 23
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Mouse actions

Mouse over actions

Passing the mouse over the molecules of the structure will highlight them and show their information in the legend on
the bottom right of the stage. Click here to see how to enable the legend.

Mouse click actions

• Clicking with the mouse left button on an atom while pressing the Alt or 2/7 key will place a Label close to this
atom. Click here to see how to edit labels.

• Clicking consecutively on two atoms with the mouse left button will draw and calculate the distance in
ångströms between these two atoms. Click here to see how to edit distances.

• Clicking consecutively on three atoms with the mouse right button while pressing the Ctrl key will draw and
calculate the angle in degrees between these three atoms. Click here to see how to edit angles.

4.2 Timeline

TheTimeline, placed at the bottom part of the application, allows the users to control and edit the clips and the keyframes
that shape the representation.

4.2.1 Timer

Placed at the top left corner of the Timeline, indicates the exact time where the cursor is.
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4.2.2 Create new timeline item

This menu allows to create new items in the timeline:

Clip

Creates a new clip in the timeline. Note that for creating a new clip an existing one must be selected. The new clip will
be added after this selected clip. If there is not enough space, the new clip will be added at the end of the timeline.
Shortcut: ⌘/Ctrl + ⇧ + C

Cloned Clip

Clones an existing clip from the timeline. Note that for cloning a new clip an existing one must be already selected in
order to clone it. The new clip will be added after this selected clip. If there is not enough space, the new clip will be
added at the end of the timeline.
Shortcut: ⌘/Ctrl + ⌥/Alt + C

Transition

Creates a transition between two clips. Two consecutive keyframes of different clips with a minimum gap of 400ms
between them must be selected before performing this action.
Shortcut: ⌘/Ctrl + ⇧ + T
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Fade In

Creates a Fade In transition before a clip. The initial keyframe of the clip must be selected before performing this
action. There must be a minimum gap of 480ms between the previous keyframe and the one selected.
Shortcut: ⌘ + ⇧ + I formacOS, Ctrl + Alt + I forWindows / Ubuntu

Fade Out

Creates a Fade Out transition after a clip. The final keyframe of the clip must be selected before performing this
action. There must be a minimum gap of 480ms between the next keyframe and the one selected.
Shortcut: ⌘/Ctrl + ⇧ + O

Description

Creates a new description in the timeline.
Shortcut: ⌘/Ctrl + ⇧ + D

4.2.3 Timeline menu

In thismenu, divided into four areas, there can be found all the possible actions to apply to the Timeline.

Remove

The remove button allows the user to remove the selected clip or transition. For the sake of security, the button must
be clicked twice.

Timeline controls

This submenu has the actions for controlling the Timeline area.
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Reset timeline

Clicking this button resets the Timeline editor: disables the PanMode (if enabled), resets the Zoom to the initial value
(if changed) and moves the cursor to the beginning.
Shortcut: ⌘/Ctrl + ⌥/Alt + R

Pan mode

Clicking this button enables / disables the Pan Mode, which allows to drag the whole Timeline editor.
Shortcut: ⌘/Ctrl + ⌥/Alt + A

Zoom

Clicking this button enables / disables the Zoom Mode, which allows to zoom into the Timeline editor.
Shortcut: ⌘/Ctrl + ⌥/Alt + Z
Tips: Once the zoom mode is enabled, the default zoom type is Zoom In. For doing Zoom Out, click ⌘/Ctrl. Zoom
can be applied as well just clicking Ctrl (any OS) and scrolling the mouse wheel.

Keyframes actions

This submenu has the actions for controlling the keyframes of the Timeline.

Align last keyframe

Only works with two keyframes selected: aligns the last keyframe of the selection with the first one.
Shortcut: ⌘/Ctrl + ⌥/Alt + ⇧ + ◄ / Left formacOS /Windows, Ctrl + Left for Ubuntu
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Align first keyframe

Only works with two keyframes selected: aligns the first keyframe of the selection with the last one.
Shortcut: ⌘/Ctrl + ⌥/Alt + ⇧ + ► / Right formacOS /Windows, Ctrl + Right for Ubuntu

Select all keyframes

Clicking this button select all the keyframes of the Timeline editor.
Shortcut: ⌘/Ctrl + ⇧ + K

Associate transition to clip

This button has the purpose of associating an existing transition with a clip different than the one that it was initially
associated with.
For example, we create a transition between two clips, then we decide to move or remove one of the two clips and
instead of it, generate a new one and associate with the transition. Just selecting both neighboring keyframes (one for
the clip and the other for the transition) and clicking the button will reassociate them and dissociate the transition with
the initial clip.
Shortcut: ⌘/Ctrl + ⇧ + A

Move keyframes left

Only works with two or more keyframes selected: moves all the selected keyframes to left in the Timeline editor.
Shortcut: ⌘/Ctrl + ⇧ + ◄ / Left

Move keyframes right

Only works with two or more keyframes selected: moves all the selected keyframes to right in the Timeline editor.
Shortcut: ⌘/Ctrl + ⇧ + ► / Right

28 Chapter 4. Video Editor



Biomovies Documentation, Release 0.5.1

Player

This submenu has the actions for controlling the cursor of the Timeline.

Go to first frame

Clicking this button moves the cursor to the first frame of the Timeline.
Shortcut: ⇧ + ▲ / Up

Go to previous frame

Clicking this button moves the cursor to the previous frame in the Timeline.
Shortcut: ⇧ + ◄ / Left

Play / Pause

Clicking this button plays / pauses the Timeline.
Shortcut: ⇧ + P

Go to next frame

Clicking this button moves the cursor to the next frame in the Timeline.
Shortcut: ⇧ + ► / Right
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Go to last frame

Clicking this button moves the cursor to the last frame of the Timeline.
Shortcut: ⇧ + ▼ / Down

Trajectory frames

Only when working with a trajectory, this section appears at the top right corner of the Timeline. It indicates in the first
place the position of the cursor and the total frames of the trajectory, and in the second place, between brackets, the
range of frames with which the trajectory will be played. Click here to see how to select this range in the Trajectory
editor. So, in the above image, the cursor is in the frame number 3792 of a total of 10000 for the whole trajectory, but
only the frames between the 3602 and the 6563 will be played.

Cursor / Total frames [ initial range frame - final range frame ]

4.2.4 Main structure

In the first row of the Timeline, the main structure can be edited creating / modiying new clips and transitions.

4.2.5 Descriptions

In the second row of the Timeline, Descriptions can be introduced. They can be treated and edited as clips with their
corresponding keyframes.

30 Chapter 4. Video Editor



Biomovies Documentation, Release 0.5.1

4.2.6 Timeline editor

The main timeline area or editor, is the place where all the actions related to Timeline such as select clip / transition,
move them, select keyframes and so on.

4.2.7 Tips

• For selecting a clip, click with the left mouse button on the clip clicking Ctrl (for any OS) at the same time.
• The timeline zoom can also be applied via scroll mouse or trackpad and pressing the Ctrl key at the same time.
• Multiple keyframes can be selected just clicking and dragging over the Timeline Editor.

For more tips, see the tips section.

4.3 Representations

The Representations panel is located at right of the stage and is used for:
• Changing the representation properties of the structure selecting a clip or a keyframe in the Timeline. That
means that each clip can have different representations.

• Modifying the settings of a trajectory for each selected clip or keyframe in the Timeline. That means that the
trajectory can have different settings for each clip.

• Adjusting the features for each selected description text in the Timeline. That means that each description text
can have different features.
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Representations for clips and Trajectory settings

Description settings
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4.3.1 Keyframes / Clips

When selecting a clip or a keyframe in the Timeline, the above editor module appears on the Representations area.

Menu

This menu is common for all the representations of the selected clip.

Create new representation

Clicking this button will create a new representation for the structure in the selected clip.

Hide all

Clicking this button will hide in the stage all the representations for the structure in the selected clip.
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Collapse all

Clicking this button will collapse all the representations editormodules for the structure in the selected clip. It doesn’t
affect the representation.

Edit representation

Each time we click the Create new representation a new representation is created and, therefore, a new Edit repre-
sentation module is added. Each one of these representations are applied to the selected clip. For applying different
representations to a different clip, click on this other clip in the Timeline.

Representation menu

The first line of the editor holds several actions related with the representation.

Representation name

Clicking this box allows to edit the name of the representation.

Hide representation

Clicking this button will hide this representation in the stage.

Clone representation

Clicking this button will clone this representation.
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Center in this representation

Clicking this button will center the stage view in the molecules selected in this representation.

Remove representation

Clicking this button will remove completely this representation.

Collapse representation editor

Clicking this button will collapse this representation editor. It doesn’t affect the representation.

Selection

The Selections are used for applyingmolecular selections to the selected representation.

Standard selection

By default, Biomovies provide a list of predefined selections:
• All
• Side Chain
• Side Chain Attached
• Backbone
• Protein
• Nucleic
• RNA
• DNA
• Hetero
• Ligand
• Ion
• Saccharide / Sugar
• Polymer
• Water
• Hydrogen
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• Helix
• Sheet
• Turn
• Small
• Nucleophilic
• Hydrophobic
• Aromatic
• Amid
• Acidic
• Basic
• Charged
• Polar
• Non Polar
• Cyclic
• Aliphatic
• Bonded
• Ring

Custom selection

Additionally, a custom selection is provided as well. When selected, the dropdown menu described below changes to a
new structure:

The custom selection is divided into three sections:
Back to standard selection button

Clicking this button backs to the dropdown menu with the list of predefined selections.
Selection input text
In this text field, users can add a custom selection written inNGL viewer Selection Language . Please visit the Selection
language section of the NGL Viewer manual before starting with this section.
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Two different chains selected via custom selection
Distance-based selection button

When clicked, gets the atoms that are within a certain distance of the selection.

It adds two new fields as well: Whole residues and Distance.
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Common custom selection: all the molecules of the chain D are represented
When clicking this button, all the atoms that are within a certain distance of the selection will be given instead of the
selection itself.

Distance-based custom selection: all the atoms within a distance of 7Å of the chain D are represented
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If theWhole residues switch button is enabled, all the molecules that have at least one atom within a distance of the
selection will be given instead of the selection itself.

Distance-based custom selection: all the molecules that have at least one atom within a distance of 7Å of the chain D are
represented

Opacity

Through this slider, the opacity of the representation varies. Note that due to an incompatibility of NGL Viewer, opacity
in multilayer projects can generate some issues. So creating multiple representations with different degrees of opacity
can give non desired outcomes.

Molecular representation

The structure can be displayed using a variety ofmolecular representations:

Backbone

Cylinders connect successive residues of unbroken chains by their main backbone atoms, which are .CA atoms in case of
proteins and C4’/C3’ atoms for RNA/DNA, respectively.
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The Backbone representation allows to modify the radius of the backbone.

Ball and stick

Atoms are displayed as spheres (balls) and bonds as cylinders (sticks).
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The Ball and stick representation allows to modify the radius of the balls (atoms) and the sticks (bonds).

Cartoon

The main backbone atoms (see backbone) of successive residues in unbroken chains are connected by a smooth trace.
The trace is expanded perpendicular to its tangent with an elliptical cross-section. The major axis points from .CA in the
direction of the .O in case of proteins and from the C1’/C3’ to C2’/O4’ for RNA/DNA, respectively.
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The Cartoon representation allows to modify the radius of the trace.
Due to a shortcoming of NGL Viewer, the cartoon and ribbon representations only can show four or more consecutive
residues.

Hyperball

A derivate of the ball+stick representation (pioneered by HyperBalls project) in which atoms are smoothly connected by
an elliptic hyperboloid.
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Licorice

A variant of the ball+stick representation where balls and sticks have the same radius.
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The Licorice representation allows to modify the radius of the balls (atoms) and the sticks (bonds).

Line

Bonds are displayed by a flat, unshaded line.
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Ribbon

A thin ribbon is displayed along the main backbone trace.

46 Chapter 4. Video Editor



Biomovies Documentation, Release 0.5.1

Due to a shortcoming of NGL Viewer, the cartoon and ribbon representations only can show four or more consecutive
residues.

Rope

A rope-like protein fold abstraction well suited for coarse-grained structures. In this representation a tube follows the
center points of local axes. The result is similar to what is shown by the Bendix tool .
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Spacefill

Atoms are displayed as a set of space-filling spheres.
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The Spacefill representation allows to modify the radius of the spheres.

Surface

Displays the molecular surface and its variants.
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Trace

A flat, unshaded line is displayed along the main backbone trace.
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Tube

Essentially like cartoon but with the aspectRatio fixed at a value of 1.0.
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Base

Simplified display of RNA/DNA nucleotides, best used in conjunction with a cartoon representation. Here, a stick is
drawn connecting the sugar backbone with a nitrogen in the base (.N1 in case of adenine or guanine, .N3 in case of
thymine or cytosine).
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The Base representation allows to modify the radius of the sticks.

Color scheme

Each loaded structure can be displayed using a variety of color schemes:

Atom index

Color by atom index.
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B-factor

Color by b-factor.
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Chain id

Color by chain id.
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Chain index

Color by chain index.
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Element

Color by chemical element.
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Hydrophobicity

Color by hydrophobicity.
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Model index

Color by model index.
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Random

Color atoms / molecules randomly.
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Residue index

Color by residue index.
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Residue name

Color by residue name.
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Secondary structure

Color by secondary structure.
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Uniform

Color by uniform color selected from the color picker that appears at right of the dropdown menu when this option is
selected.
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Radius

Through this slider, the radius can be modified in the next molecular representations:
• Backbone
• Ball and stick
• Cartoon
• Licorice
• Spacefill
• Base

4.3.2 Trajectories

When working with a project with a topology and a trajectory and selecting a clip or a keyframe in the Timeline, the
above editor module appears on the Representations area.
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By default it’s disabled. That means that, when we start a new project with a trajectory, this trajectory is not applied to
the structure until the Play trajectory for this clip switch button is enabled.

Enable / Disable trajectory

When enabling the Play trajectory for this clip switch button, the editor expands all the settings. From now on, the
trajectory is active for the clip selected in the Timeline and we can check it by clicking for example the Play button in
the Timeline,
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Range

Initially set from the first to the last frame of the trajectory, defines a range of frames with which the trajectory will be
played.
Taking into account that for long trajectories, the modification of the range can be annoying, a couple of features have
been introduced:

• On the one hand, both of the numbers at the right top of the range are editable. Click on both of them in order
to introduce the desired frame.

• On the other hand, range values can be adjusted via keyboard with the following shortcuts:
– ⌘/Ctrl + ⌥/Alt + 1 decreases initial frame
– ⌘/Ctrl + ⌥/Alt + 2 increases initial frame
– ⌘/Ctrl + ⌥/Alt + 3 decreases final frame
– ⌘/Ctrl + ⌥/Alt + 4 increases final frame

For more tips, see the tips section. For more shortcuts, see the shortcuts section.

Step

Defines the number of frames between playing steps.

Timeout

Timeout between playing frames (40ms per unit).

Play in reverse

If enabled plays the trajectory backwards.

Fit clip in timeline

Adjust the selected clip in Timeline size with the trajectory length. Beside the switch button there is a text that,
dynamically, updates the number of frames of the trajectory after modifying the range and the time of the clip in ms
after modifying step and / or timeout.
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4.3.3 Descriptions

As explained in the Descriptions section, users can add descriptive texts to the Timeline. Clicking on a keyframe or a
description in the Timeline, the above editor module appears on the Representations area.
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Description text

This text box allows to edit the text shown in the Timeline.
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Font size

Font size of the text shown in the Timeline.
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Font family

Font family for the text shown in the Timeline.
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List of available fonts:
• Anton
• Arial
• Avenir
• Caveat
• Merriweather
• Quicksand
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Font Color

Font color of the text shown in the Timeline.

Background Color

Background color of the text shown in the Timeline.
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Background Visibility

Wheter or not to show the background of the text shown in the Timeline.
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Description position

Placement of the text in the stage.
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There is a list of available predefined positions. The first parameter is about vertical position while the second is about
the horizontal one:

• Top Left
• Top Center
• Top Right
• Middle Left
• Middle Center
• Middle Right
• Bottom Left
• Bottom Center
• Bottom Right
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4.4 Status Bar

Status bar
The status bar is at the bottom of the application. It can be enabled / disabled via menu (View > Status Bar)

4.4.1 Tips

This section of the status bar shows tips depending on the area of the application where the mouse is located. There are
tips for:

• Stage
• Tools
• Controls
• Timeline
• Splitter

4.4.2 Project status

This section of the status bar shows the current status of the project: either the last time it was saved or a prompt warning
that the project hasn’t been saved yet.

4.4.3 Version

This section of the status bar shows the current version of the application.
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4.4.4 Theme

Clicking on this section of the status bar the application theme will toggle between dark and light. This option can be
toggled as well via menu (View > Light Theme or View > Dark Theme)
Shortcut: ⌥/Alt + ⇧ + H
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FIVE

CREATE VIDEOS

The process of creating a video with Biomovies is really straightforward. Once the edition of the movie is finished,
just click one of the three options available to start recording.

5.1 Create New Preview

A preview is, in fact, a screen record. Biomovies plays the Timeline in real time and records it. Thus, the resolution is
not standard, but depends on your screen.
For recording a New Preview, go to menu Create Video > New Preview or use the shortcut ⌘/Ctrl + P. This action will
put Biomovies in full screen and will open a new window as well.

In this new window, users can choose the resolution and the frame rate for the new video.
• As explained before, the resolution depends on the screen on which Biomovies is being executed. Therefore, if
you have a Full HD monitor, the movie can have this resolution. All the available resolutions have the aspect ratio
of the screen. There are four available resolutions:
– XL: screen size width (1920x1200 in the figure above)
– L: width 1280, height according to screen aspect ratio (1280x800 in the figure above)
– M: width 1024, height according to screen aspect ratio (1024x640 in the figure above)
– S: width 800, height according to screen aspect ratio (800x500 in the figure above)

• As for the frame rate, users can choose between 25, 20 or 10 frames per second.
Once the Record button is pressed, the render process starts. This render process consists of recording the movie in real
time, so it will take the same length of the Timeline.
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After the render process is finished, it starts the video generation. This part can take more or less time depending on the
resolution chosen and the resources of the computer where Biomovies is being executed. Once the video generation
is finished, a system dialog is shown to ask the user where to save the video.
Tip: in macOS, the process of recording the screen captures the mouse as well, so though this is a preview video, if
you don’t want to see the mouse in the video, it’s recommended to have it inside the Create Preview window. As the
application only records the content of themain window, the mouse remains hidden in the render process.
All the Preview Videos generated by Biomovies are inMP4 format and H.264 compression. Take into account that, as
themovie size depends on the screen size, not always the outcome will be a standard resolution, for doing that, please
use the Create New Movie option.

5.2 Create New Movie

The process of the creation of a New Movie differs from the Preview and the GIF in one main feature: in this case,
the render process consists of capturing and saving as images all the frames composing the movie. After saving all
this images, the Movie is generated. Thus, the rendering time is not in real time, but it depends on the duration of the
Timeline, the chosen resolution and the hardware specificacions of the computer where Biomovies is being executed.
For recording a New Movie, go to menu Create Video > New Movie or use the shortcut ⌘/Ctrl + M. This action will put
Biomovies in full screen and will open a new window as well.

In this new window, users can choose the resolution of the new video and, optionally, the raw images folder where the
rendering images will be saved.

• In this case, the resolution doesn’t depends on the screen on which Biomovies is being executed. Therefore,
there are three available standard resolutions, all of them with a 16:9 aspect ratio:

– HD: or HD 720p, 1280x720
– FULLHD: or Full HD 1080p, 1920x1080
– QHD: or 1440p, WQHD, 2K, 2560x1440

• Clicking in the raw images folder button will allow to save the render images in the selected place. Otherwise
they will be stored in a temporary folder.

Once the Record button is pressed, the render process starts. This render process consists of saving one image for each
frame of the Timeline, so the time it will take depends on multiple factors, such as the total video length, the chosen
resolution or the hardware specifications of the computer in which Biomovies is being executed.
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After the render process is finished, it starts the video generation. This part can take more or less time depending on the
resolution chosen and the resources of the computer where Biomovies is being executed. Once the video generation
is finished, a system dialog is shown to ask the user where to save the video.
Tip: it is highly recommended to have the Letterboxing tool enabled during the process of generating a movie. After
enabling it, two stripes will appear showing to the user which parts of the stage will be rendered and which not. In some
cases (when the screen aspect ratio is 16:9) these stripes won’t appear.

The render process will only take into account the part of the stage between the stripes
All theMovie Videos generated by Biomovies are inMP4 format and H.264 compression.

5.3 Create New GIF

The process of creating a new animated GIF is very similar to the one seen above for creating a New Preview. That
means, a screen record. Biomovies plays the Timeline in real time and records it. Thus, the resolution is not standard,
but depends on your screen.
For recording a New GIF, go to menu Create Video > New GIF or use the shortcut ⌘/Ctrl + G. This action will put
Biomovies in full screen and will open a new window as well.

In this new window, users can choose the resolution and the frame rate for the new animated GIF.
• As explained before, the resolution depends on the screen on which Biomovies is being executed. In this case,
and for the sake of the efficiency, it is not allowed to generate an animated GIF with the size of the whole screen.
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Take into account that animated GIFs have not the same compression and quality of aMP4 video. A GIF can
be useful for putting a small video inside a markdown file, but for showing a long video in full screen, use always
a video. All the available resolutions have the aspect ratio of the screen. There are four available resolutions:

– L: width 1024, height according to screen aspect ratio (1024x640 in the figure above)
– M: width 800, height according to screen aspect ratio (800x500 in the figure above)
– S: width 640, height according to screen aspect ratio (640x400 in the figure above)
– XS: width 480, height according to screen aspect ratio (480x300 in the figure above)

• As for the frame rate, users can choose between 2, 5 or 10 frames per second.
Once the Record button is pressed, the render process starts. This render process consists of recording the movie in real
time, so it will take the same length of the Timeline.
After the render process is finished, it starts the video generation. This part can take more or less time depending on the
resolution chosen and the resources of the computer where Biomovies is being executed. Once the video generation
is finished, a system dialog is shown to ask the user where to save the GIF file.
Tip: inmacOS, the process of recording the screen captures themouse as well, so if you don’t want to see the mouse in
the video, it’s recommended to have it inside the Create GIF window. As the application only records the content of
the main window, the mouse remains hidden in the render process.
All the animated GIFs generated by Biomovies are, obviously, in GIF format.
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SIX

UTILITIES

6.1 FAQs

6.1.1 How easy is to install Biomovies?

Biomovies is not difficult to install, however, depending on the version of your operating system, there are some
workarounds worth taking into account. See the documentation for installing in macOS,Windows and Ubuntu.

6.1.2 Which are the software / hardware requirements?

These are the recommended requirements:
• *macOS:Mac OSX 10.12+ supported, 16GB of RAM recommended
• *Linux: Ubuntu 18.04 or greater, 16GB of RAM recommended
• *Windows: Windows 10, 16GB of RAM recommended

6.1.3 How to start a new project?

Please visit the Getting Started section of the documentation.

6.1.4 How to edit a movie?

Please visit the Video Editor section of the documentation. In this section, you will find exhaustive descriptions about all
the sections of the editor, such as the Stage, the Timeline or the Representations.

6.1.5 How to export my own videos?

Please visit the Create Videos section of the documentation. In this section, there is a broad explanation about how to
create a New Preview video, a New Movie and a New GIF.
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6.2 Shortcuts

6.2.1 Home screen

Feature | macOS | Ubuntu |Windows
About
Hide biomovies | ⌘H | |
Hide Others | ⌥⌘H | |
Quit biomovies | ⌘Q | Ctrl+Q | Ctrl+Q
Project
New Project | ⇧⌘N | Ctrl+Shift+N | Ctrl+Shift+N
New Project with Trajectory | ⇧⌘T | Ctrl+Shift+T | Ctrl+Shift+T
Open Project | ⇧⌘O | Ctrl+Shift+O | Ctrl+Shift+O
Import Template | ⇧⌘I | Ctrl+Alt+I | Ctrl+Alt+I
Help
Documentation | ⌘D | Ctrl+D | Ctrl+D

6.2.2 Video Editor

Feature | macOS | Ubuntu |Windows
About
Hide biomovies | ⌘H | |
Hide Others | ⌥⌘H | |
Quit biomovies | ⌘Q | Ctrl+Q | Ctrl+Q
Edit
Undo | ⌘Z | Ctrl+Z | Ctrl+Z
Redo | ⇧⌘Z | Ctrl+Shift+Z | Ctrl+Shift+Z
Cut | ⌘X | Ctrl+X | Ctrl+X
Copy | ⌘C | Ctrl+C | Ctrl+C
Paste | ⌘V | Ctrl+V | Ctrl+V
Project
Save Project | ⌘S | Ctrl+S | Ctrl+S
Save Project As | ⇧⌘S | Ctrl+Shift+S | Ctrl+Shift+S
Export Project As Template | ⇧⌘E | Ctrl+Shift+E | Ctrl+Shift+E
Close Project | ⌘W | Ctrl+W | Ctrl+W
View
Stage | ⌥⇧S | Alt+Shift+S | Alt+Shift+S
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Timeline | ⌥⇧T | Alt+Shift+T | Alt+Shift+T
Representations | ⌥⇧R | Alt+Shift+R | Alt+Shift+R
Tools | ⌥⇧O | Alt+Shift+O | Alt+Shift+O
Status Bar | ⌥⇧B | Alt+Shift+B | Alt+Shift+B
Theme | ⌥⇧H | Alt+Shift+H | Alt+Shift+H
Timeline > New Item
Create New Clip | ⇧⌘C | Ctrl+Shift+C | Ctrl+Shift+C
Create New Cloned Clip | ⌥⌘C | Ctrl+Alt+C | Ctrl+Alt+C
Create New Transition | ⇧⌘T | Ctrl+Shift+T | Ctrl+Shift+T
Create New Fade In Transition | ⇧⌘I | Ctrl+Alt+I | Ctrl+Shift+I
Create New Fade Out Transition | ⇧⌘O | Ctrl+Shift+O | Ctrl+Shift+O
Create New Description | ⇧⌘D | Ctrl+Shift+D | Ctrl+Shift+D
Timeline > Controls
Reset Timeline | ⌥⌘R | Ctrl+Alt+R | Ctrl+Alt+R
Pan Mode | ⌥⌘A | Ctrl+Alt+A | Ctrl+Alt+A
Zoom Mode | ⌥⌘Z | Ctrl+Alt+Z | Ctrl+Alt+Z
Timeline > Keyframes Actions
Align to First | ⌥⌘⇧◄ | Ctrl+Left | Ctrl+Alt+Shift+Left
Align to Last | ⌥⌘⇧► | Ctrl+Right | Ctrl+Alt+Shift+Right
Select all Keyframes | ⇧⌘K | Ctrl+Shift+K | Ctrl+Shift+K
Associate transition to clip | ⇧⌘A | Ctrl+Shift+A | Ctrl+Shift+A
Move to Left | ⇧⌘◄ | Ctrl+Shift+Left | Ctrl+Shift+Left
Move to Right | ⇧⌘► | Ctrl+Shift+Right | Ctrl+Shift+Right
Timeline > Player Go to First Frame | ⇧▲ | Shift+Up | Shift+Up
Go to Previous Frame | ⇧◄ | Shift+Left | Shift+Left
Play / Pause | ⇧P | Shift+P | Shift+P
Go to Next Frame | ⇧► | Shift+Right | Shift+Right
Go to Last Frame | ⇧▼ | Shift+Down | Shift+Down
Create Video
New Preview | ⌘P | Ctrl+P | Ctrl+P
New Movie | ⌘M | Ctrl+M | Ctrl+M
New GIF | ⌘G | Ctrl+G | Ctrl+G
Close Video Window | ⇧⌘W | Ctrl+Shift+W | Ctrl+Shift+W
Help
Documentation | ⌘D | Ctrl+D | Ctrl+D
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6.2.3 Specific Trajectory shortcuts

Feature | macOS | Ubuntu |Windows
Decreases initial frame of trajectory | ⌥⌘1 | Ctrl+Alt+1 | Ctrl+Alt+1
Increases initial frame of trajectory | ⌥⌘2 | Ctrl+Alt+2 | Ctrl+Alt+2
Decreases final frame of trajectory | ⌥⌘3 | Ctrl+Alt+3 | Ctrl+Alt+3
Increases final frame of trajectory | ⌥⌘4 | Ctrl+Alt+4 | Ctrl+Alt+4

6.3 Tips

In this section there is a summary of the Tips already explained in the rest of sections.

6.3.1 Stage mouse actions

Mouse drag / wheel

Actions of zoom in and zoom out can be done with the scroll mouse or the trackpad of a laptop, besides, rotation and
translation can be applied as well:

• Clicking on the stage with the left button and dragging will rotate the view.
• Clicking on the stage with the right button and dragging will translate the view.
• Mouse wheel (or using the trackpad with two fingers) on the stage will zoom in or zoom out.

Mouse over actions

Passing the mouse over the molecules of the structure will highlight them and show their information in the legend on
the bottom right of the stage. Click here to see how to enable the legend.

Mouse click actions

• Clicking with the mouse left button on an atom while pressing the Alt or 2/7 key will place a Label close to this
atom. Click here to see how to edit labels.

• Clicking consecutively on two atoms with the mouse left button will draw and calculate the distance in
ångströms between these two atoms. Click here to see how to edit distances.

• Clicking consecutively on three atoms with the mouse right button while pressing the Ctrl key will draw and
calculate the angle in degrees between these three atoms. Click here to see how to edit angles.
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6.3.2 Modify trajectory range

Apart from the obvious range slider, there are two more ways available in order to modify the trajectory range:
• On the one hand, both of the numbers at the right top of the range are editable. Click on both of them in order
to introduce the desired frame.

• On the other hand, range values can be adjusted via keyboard with the following shortcuts:
– ⌘/Ctrl + ⌥/Alt + 1 decreases initial frame
– ⌘/Ctrl + ⌥/Alt + 2 increases initial frame
– ⌘/Ctrl + ⌥/Alt + 3 decreases final frame
– ⌘/Ctrl + ⌥/Alt + 4 increases final frame

6.3.3 Timeline

Select single clip in Timeline Editor

For selecting a clip, click with the left mouse button on the clip pressing Ctrl key (for any OS) at the same time. A clip
can be selected as well just clicking and dragging over the Timeline Editor, but depending on the amount of clips or
transitions and the selected zoom for the editor, it can be difficult to select only the desired clip.

Select clips / keyframes in Timeline Editor

Multiple clips / keyframes can be selected just clicking and dragging over the Timeline Editor.

Zoom

• The Timeline Editor zoom can be applied just clicking Ctrl (any OS) and scrolling themouse wheel.
• Once the zoom mode is enabled via Timeline controlsmenu, the default zoom type is Zoom In. For doing Zoom
Out, click ⌘/Ctrl.

6.3.4 Splitter

There is a splitter between the three main areas of the Video Editor. For changing the size of any of these areas, just
put themouse over one of the two splitters, click over it and drag the mouse.

6.3.5 Theming

At the moment of launching the current release, there are two themes available: Dark (default) and Light. For toggling
between them, there are three options:

• Click the Theme button on the status bar.
• Via menu: View > Light / Dark Theme

• Shortcut: ⌥/Alt + ⇧ + H
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6.3.6 Show / hide Video Editor areas

All the areas of the Video Editor can be hidden totally (via menu or shorcut) or partially (via splitter) in case of the
Stage, Representations and Timeline.

Show Stage

The Stage is the only area of the Video Editor that can’t be totally hidden, because it is themain area in the application.
For showing it occupying the whole application:

• Via menu: View > Stage

• Shortcut: ⌥/Alt + ⇧ + S
It can be partially hidden as well using the splitter.

Show / hide Timeline

For showing the Timeline (in case it is totally or partially hidden):
• Via menu: View > Timeline

• Shortcut: ⌥/Alt + ⇧ + T
It can be partially shown / hidden as well using the splitter.

Show / hide Representations

For showing the Representations (in case it is totally or partially hidden):
• Via menu: View > Representations

• Shortcut: ⌥/Alt + ⇧ + R
It can be partially shown / hidden as well using the splitter.

Show / hide Tools

For showing / hiding the Tools:
• Via menu: View > Tools

• Shortcut: ⌥/Alt + ⇧ + O
This menu is draggable around all the stage and can be collapsed / expanded by clicking twice on the handler.
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Show / hide Status Bar

For showing / hiding the Status Bar:
• Via menu: View > Status Bar

• Shortcut: ⌥/Alt + ⇧ + B

6.3.7 Hide mouse when recording Preview Video or GIF

In macOS, the process of recording the screen captures the mouse as well, so though this is a preview video, if you
don’t want to see the mouse in the video or animated GIF, it’s recommended to have it inside the Create GIF / Create
Preview window. As the application only records the content of the main window, the mouse remains hidden in the
render process.

6.3.8 Use Letterboxing for creating Movies

It is highly recommended to have the Letterboxing tool enabled during the process of generating a movie. After enabling
it, two stripes will appear showing to the user which parts of the stage will be rendered and which not. In some cases
(when the screen aspect ratio is 16:9) these stripes won’t appear.
Remember that the Letterboxing is useful only when recording a Movie, is not necessary for Previews or animated
GIFs.

6.3.9 Use Asociate transition to clip button to fix bugs

As this is an experimental software, sometimes it can appear some bug, specially in the Timeline. So in case you detect
that a transition and one of its corresponding clips are messed up, try to use this button as explained in the interface
section.

6.3.10 Use Reset timeline button to fix bugs

As this is an experimental software, sometimes it can appear some bug, specially in the Timeline. So in case you detect
that the bounds of the keyframes don’t work properly, try to use this button as explained in the interface section .

6.3. Tips 89


	Biomovies
	Brief description
	Demo
	Documentation & help
	Software / Hardware requirements
	Installation
	Features
	Technology
	Acknowledgements
	Copyright & licensing

	Installation
	macOS
	Universal / Intel
	Apple silicon / ARM64

	Ubuntu
	deb
	Command line
	Graphical User Interface

	AppImage
	Command line
	Graphical User Interface


	Windows

	Getting started
	New Project
	New Project with Trajectory
	Open Project
	Import Template
	Help
	Common shortcuts

	Video Editor
	Stage
	Tools
	Center
	Background
	Measurements
	Distances
	Angles

	Labels
	Camera type
	Center view in atom
	Enable / Disable legend
	Open keyframe editor
	Enable / Disable letterboxing

	Structure Stage
	Zoom / Drag
	Mouse actions
	Mouse over actions
	Mouse click actions



	Timeline
	Timer
	Create new timeline item
	Clip
	Cloned Clip
	Transition
	Fade In
	Fade Out
	Description

	Timeline menu
	Remove
	Timeline controls
	Reset timeline
	Pan mode
	Zoom

	Keyframes actions
	Align last keyframe
	Align first keyframe
	Select all keyframes
	Associate transition to clip
	Move keyframes left
	Move keyframes right

	Player
	Go to first frame
	Go to previous frame
	Play / Pause
	Go to next frame
	Go to last frame

	Trajectory frames

	Main structure
	Descriptions
	Timeline editor
	Tips

	Representations
	Keyframes / Clips
	Menu
	Create new representation
	Hide all
	Collapse all

	Edit representation
	Representation menu
	Representation name
	Hide representation
	Clone representation
	Center in this representation
	Remove representation
	Collapse representation editor

	Selection
	Standard selection
	Custom selection

	Opacity
	Molecular representation
	Backbone
	Ball and stick
	Cartoon
	Hyperball
	Licorice
	Line
	Ribbon
	Rope
	Spacefill
	Surface
	Trace
	Tube
	Base

	Color scheme
	Atom index
	B-factor
	Chain id
	Chain index
	Element
	Hydrophobicity
	Model index
	Random
	Residue index
	Residue name
	Secondary structure
	Uniform

	Radius


	Trajectories
	Enable / Disable trajectory
	Range
	Step
	Timeout
	Play in reverse
	Fit clip in timeline

	Descriptions
	Description text
	Font size
	Font family
	Font Color
	Background Color
	Background Visibility
	Description position


	Status Bar
	Tips
	Project status
	Version
	Theme


	Create Videos
	Create New Preview
	Create New Movie
	Create New GIF

	Utilities
	FAQs
	How easy is to install Biomovies?
	Which are the software / hardware requirements?
	How to start a new project?
	How to edit a movie?
	How to export my own videos?

	Shortcuts
	Home screen
	Video Editor
	Specific Trajectory shortcuts

	Tips
	Stage mouse actions
	Mouse drag / wheel
	Mouse over actions
	Mouse click actions

	Modify trajectory range
	Timeline
	Select single clip in Timeline Editor
	Select clips / keyframes in Timeline Editor
	Zoom

	Splitter
	Theming
	Show / hide Video Editor areas
	Show Stage
	Show / hide Timeline
	Show / hide Representations
	Show / hide Tools
	Show / hide Status Bar

	Hide mouse when recording Preview Video or GIF
	Use Letterboxing for creating Movies
	Use Asociate transition to clip button to fix bugs
	Use Reset timeline button to fix bugs



